Compatibility

Our agent is designed to work with most use-cases. Below you will find details on versioning, application stacks, and known incompatibility issues.

Version Support

The Bearer Agent supports Python v3.5 or higher, and Python 2.7

HTTP package Support

Due to the nature of how the agent hooks into the underlying HTTP calls in an application, we currently support a limited number of HTTP packages. Any package listed below, and those that are built atop these packages (such as requests), will work with the Bearer Agent.

Python 3.X

Python 2.7

If your application is using a package that isn't supported, let us know!

Known limitations

Features not supported

The Python agent currently supports a subset of Bearer's features, including the primary monitoring experience. The following are coming soon, but not currently supported:

  • Remediations: Currently, the Python Agent does not support active remediations.

  • Call-by-call filter matching in anomaly rules: Anomalies are supported, however the call-by-call filter matching is not currently available in the Python Agent.

Serverless functions-as-a-service

While the agent will work in many function-as-a-service scenarios, such as in AWS lambda functions or Google Cloud functions, some remediations types (like retrying failed requests) may not work as expected if the lifespan of the function is too short.

Receiving Support

If you experience an issue installing or using the agent, let us know! You can contact us directly, chat with a member of the team using the Intercom icon in the lower right corner of this page, or check out our Help Center.